Editor/Parser bug

7 replies [Last post]
warnerdan42
User offline. Last seen 12 years 30 weeks ago. Offline
Joined: 04/21/2009
Posts:

There is an error in how minus signs are handled in some kinds of edits.

This is the simplest example I have found
1. Enter subtract template
2. Enter 1 on the left
3. Enter the fraction template on the right
4. Enter 2 in the numerator
5. Enter 1 in the denominator

The app correctly displays
1 - 2/1 = -1

6. Delete the value in the denominator
7. Delete the denominator

The app incorrectly displays
1 - 2 = 3

If you email the formula, the app sends
1 + 2 = 3

This is also what the app displays if you exit and return.

Brad Larson
Brad Larson's picture
User offline. Last seen 4 years 50 weeks ago. Offline
Joined: 05/14/2008
Posts:

You're correct, that is an error. It looks like the subtraction bit is being reset when the denominator is removed. I'll fix that for the next update.

Anonymous

A similar bug without deletions.

1. Enter 1+2
2. Highlight the 2 and enter the subtract template
3. Enter 3 into the new box

The app correctly displays
1 + 2 - 3 = 0

4. Highlight the 3 and enter the fraction template
5. Enter 1 into the denominator

The app now displays
1 + 2 - 3/1 = 6

warnerdan42
User offline. Last seen 12 years 30 weeks ago. Offline
Joined: 04/21/2009
Posts:

BTW deleting the denominator in the last example does not fix things. It just displays
1 + 2 - 3 = 6

Brad Larson
Brad Larson's picture
User offline. Last seen 4 years 50 weeks ago. Offline
Joined: 05/14/2008
Posts:

This should all be fixed in the 1.01 update that I submitted for review yesterday. Hopefully the review process will be brief.

Again, sorry about that.

Brad Larson
Brad Larson's picture
User offline. Last seen 4 years 50 weeks ago. Offline
Joined: 05/14/2008
Posts:

1.01 is now on the App Store, which should resolve this bug. If any odd behavior still persists, please let me know.

Thanks again for pointing this out.

warnerdan42
User offline. Last seen 12 years 30 weeks ago. Offline
Joined: 04/21/2009
Posts:

I upgraded to version 1.01, and those bugs have been exterminated. Good work.

warnerdan42
User offline. Last seen 12 years 30 weeks ago. Offline
Joined: 04/21/2009
Posts:

I upgraded to version 1.01, and those bugs have been exterminated. Good work.

Syndicate content